29 lines
622 B
Nix
29 lines
622 B
Nix
{pkgs, ...}: {
|
|
services.searx = {
|
|
enable = true;
|
|
package = pkgs.searxng;
|
|
settings = {
|
|
server.port = 3005;
|
|
server.secret_key = "@SEARX_SECRET_KEY@";
|
|
search.formats = ["html" "json"];
|
|
};
|
|
};
|
|
# Traefik configuration specific to searx
|
|
services.traefik.dynamicConfigOptions.http = {
|
|
services.searx.loadBalancer.servers = [
|
|
{
|
|
url = "http://localhost:3005/";
|
|
}
|
|
];
|
|
|
|
routers.searx = {
|
|
rule = "Host(`search.m3tam3re.com`)";
|
|
tls = {
|
|
certResolver = "godaddy";
|
|
};
|
|
service = "searx";
|
|
entrypoints = "websecure";
|
|
};
|
|
};
|
|
}
|